Shippo is down maybe due to cloudflare outage

Incident Report for ShipHero

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:12 UTC

Monitoring

Shippo services have returned to operational status. We will continue to monitor the stability of this connection.
Posted Nov 18, 2025 - 13:39 UTC

Investigating

Shippo is down maybe due to cloudflare outage. You can use our direct USPS integration to continue generating USPS labels. Cheapest will be affected if Shippo is connected because they aren’t responding to quotes.
Posted Nov 18, 2025 - 13:25 UTC
This incident affected: Label Printing.