Printing Shipping Labels Not Working
Incident Report for ShipHero
Resolved
Apologies all! The issue has been resolved and all services have resumed normal operation.
Posted May 22, 2019 - 17:24 UTC
Identified
We are aware of the issue and are applying a fix. We estimate a resolution in 10 minutes.
Posted May 22, 2019 - 17:19 UTC
This incident affected: Label Printing.