Shippo is down
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 19:46 UTC
Monitoring
It appears Shippo has resolved the issue. Their status is still open at https://status.goshippo.com/. We continue to monitor
Posted Feb 22, 2024 - 17:16 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 22, 2024 - 17:15 UTC
Identified
The Shippo team is working on a resolution.
Posted Feb 22, 2024 - 16:38 UTC
This incident affected: Label Printing.