DHL Reports Slowness
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Nov 30, 2018 - 23:17 UTC
Monitoring
DHL has reported that there is slowness currently occurring on DHL related web services. This may result in slow generation or timeouts of DHL Shipping Labels and Cheapest label generation if you have a connected DHL account.
Posted Nov 30, 2018 - 20:03 UTC
This incident affected: Miscellaneous Services.