All ShipHero Components have been restored to operational status.
Posted Oct 20, 2025 - 23:40 UTC
Update
Update: The AWS outage has improved. ShipHero's platform team is monitoring our performance and encouraged by the mitigation by AWS and our system's ability to catch up.
Remaining known issues:
1. USPS modern, their API is still having issues 2. Order importing is still catching up. We expect it to reach synchronization with the next 2 - 4 hours
We will continue to monitor our logs and systems until all our affected component have been restored to operational
Thank you
Posted Oct 20, 2025 - 23:11 UTC
Update
Update: AWS continues to recover and stabilize infrastructure performance. While we have been able to confirm improvement with our own internal monitoring and performance tools, we are aware that our Dashboards and Searches are in the process of catching up and are " Out of Sync by several hours.. This was expected and the process to catch up and reach synchronization is in-flight.
We will update Status Page once we have caught up.
Thank you for your continued patience as we recover from this outage event.
Posted Oct 20, 2025 - 20:44 UTC
Update
AWS is recovering and therefore ShipHero is recovering. Please be patient, if you're trying to create a label and it's taking time, wait for the label to generate don't try to print again for up to 2 minutes to make sure you don't get two labels. Don't clear totes or make other changes, please wait until the system catches up.
Posted Oct 20, 2025 - 20:24 UTC
Update
AWS is currently in the process of recovering affected services. As systems are restored, we will be conducting data integrity checks.
Please refrain from taking any manual corrective actions while the system synchronizes and catches up. We appreciate your patience and understanding.
We will continue to provide period updates.
Posted Oct 20, 2025 - 14:43 UTC
Update
Update: As 09:30am Amazon Health Dashboard reported that they are making progress on resolving the issue.
We have had limited reports of intermittent latency, otherwise ShipHero is operational. ShipHero Support will continue to monitor AWS for progress updates and resolution of this incident.
This incident affected: ShipHero Mobile App, ShipHero Dashboard, Store Integrations, Label Printing, ShipHero Public API, ShipHero Authentication, Miscellaneous Services, and ShipHero Ticket Support.