Slowness being investigated

Incident Report for ShipHero

Resolved

The slowness is resolved. Thank you for your patience.
Posted Nov 06, 2025 - 18:59 UTC

Investigating

We see slowness across the system and are investigating.
Posted Nov 06, 2025 - 18:42 UTC
This incident affected: ShipHero Mobile App, ShipHero Dashboard, Label Printing, and Miscellaneous Services.