All DHL eCommerce Services Reported Unavailable
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Apr 03, 2019 - 18:34 UTC
Update
DHL are reporting this issue has been resolved.
Posted Apr 03, 2019 - 18:33 UTC
Monitoring
DHL has communicated that all DHL eCommerce Services are are unavailable. They are currently investigating the cause.
Posted Apr 03, 2019 - 17:26 UTC
This incident affected: Label Printing.