Slower than normal print times
Incident Report for ShipHero
Resolved
This issue has been resolved.
Posted Jun 01, 2020 - 14:15 UTC
Investigating
We are currently investigating an issue causing slow print times.
Posted Jun 01, 2020 - 13:54 UTC
This incident affected: Printing.