ShipHero Support Email Delay
Incident Report for ShipHero
Resolved
All emails have been processed and are appropriately syncing.
Posted 3 months ago. Jun 27, 2019 - 19:01 UTC
Investigating
We’ve been alerted to a problem with incoming support emails. While all incoming emails are being queued for delivery, they aren't currently processing into ShipHero Support mailboxes. We are currently investigating and will update here as we know more.
Posted 3 months ago. Jun 27, 2019 - 18:33 UTC
This incident affected: Support.