Shipping disruption
Incident Report for ShipHero
Resolved
We've confirmed that the issue is fully resolved. Thank you for your understanding.
Posted Sep 22, 2022 - 19:32 UTC
Monitoring
The issue has been fixed. We're monitoring.
Posted Sep 22, 2022 - 19:29 UTC
Identified
We have a major disruption of shipping. The fix is in progress and will take 20-30 minutes for the fix to take effect.
Posted Sep 22, 2022 - 19:27 UTC
This incident affected: Label Printing.