Support Emails Routing to Spam
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 16:36 UTC
Monitoring
We have identified an issue with ShipHero Support emails being routed to spam folders. A fix has been implemented but may take up to 48-hours before the issue is resolved. Please monitor your email spam folders or your customer portal for updates from ShipHero Support.
Posted Jun 09, 2020 - 15:09 UTC
This incident affected: Support.