Endicia is currently down for many customers
Incident Report for ShipHero
Resolved
Endicia says the issue is resolved.
Posted Mar 08, 2021 - 20:29 UTC
Investigating
You will get an error when attempting to print Endicia labels. Endicia is aware and has an open status - follow https://status.endicia.com/ for the latest Status on Endicia. You can use Shippo as an alternative for USPS label generation at the same price as Endicia, you can sign up for Endicia from https://app.shiphero.com/dashboard/shipping-carriers
Posted Mar 08, 2021 - 19:21 UTC
This incident affected: Miscellaneous Services.