Issue creating manual orders
Incident Report for ShipHero
Resolved
This issue has been resolved.
Posted 4 months ago. Mar 19, 2019 - 19:33 UTC
Identified
The cause has been identified and a fix is being rolled out shortly.
Posted 4 months ago. Mar 19, 2019 - 19:23 UTC
Investigating
We're investigating an issue preventing users from creating manual orders.
Posted 4 months ago. Mar 19, 2019 - 18:59 UTC
This incident affected: Dashboard.