ShipHero Customer Hub & Ticket Delays
Incident Report for ShipHero
Resolved
We appreciate your patience as we partnered with our Vendor to address an issue that was causing a delay in our ticketing system. Everything appears to be up and running, our team is currently working to respond to requests as quickly as possible.
Posted Jun 23, 2020 - 17:49 UTC
Monitoring
Our 3rd Party vendor has identified and resolved the issue impacting our support communication. We will continue to monitor the performance of the system and apologize for any delayed responses.
Posted Jun 23, 2020 - 15:26 UTC
Identified
We have escalated performance concerns with our Customer Hub and Ticketing system to our 3rd party vendor. We appreciate your patience with our delayed response times.
Posted Jun 23, 2020 - 15:09 UTC
This incident affected: ShipHero Ticket Support.