Shippo is down

Incident Report for ShipHero

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 17:22 UTC

Monitoring

Shippo says they have resolved the issue.
Posted Mar 16, 2026 - 17:21 UTC

Investigating

Shippo has a partial outage which will block Cheapest if you have Shippo connected. If you use our direct USPS Modern solution you won't be affected. See https://status.goshippo.com/ for status of Shippo.
Posted Mar 16, 2026 - 16:51 UTC
This incident affected: Label Printing.