Printing Errors While Shipping
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 19:08 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2020 - 19:08 UTC
Investigating
We are currently investigating an issue that is impacting printing.
Posted Feb 26, 2020 - 18:50 UTC
This incident affected: Label Printing.