Latency - Order Imports

Incident Report for ShipHero

Resolved

This incident has been resolved.
Posted May 13, 2025 - 22:54 UTC

Identified

The root cause had been identified and we have successfully contained the issue.
Posted May 13, 2025 - 22:52 UTC

Update

We are continuing to investigate this active issue and are monitoring progress on restoration of service performance.
Posted May 13, 2025 - 22:03 UTC

Investigating

We are currently investigating a performance degradation between Shopify and ShipHero causing order imports to take longer than usual.
Posted May 13, 2025 - 21:20 UTC
This incident affected: Store Integrations.