Errors detected during label, barcodes, attachment and other files handling

Incident Report for ShipHero

Resolved

We have determined the cause of the issue and services are performing as usual
Posted Jun 18, 2025 - 09:14 UTC

Investigating

We are currently investigating this issue
Posted Jun 18, 2025 - 09:01 UTC
This incident affected: ShipHero Dashboard and Label Printing.