ShipHero Software Support Emails Not Being Received
Incident Report for ShipHero
Resolved
ShipHero Software support emails going to support@shiphero.com are now being received immediately. If you submitted a ticket during this incident and received "Message not delivered," please resend it, and our support team will respond as quickly as possible.
Posted Jul 06, 2023 - 17:22 UTC
Identified
ShipHero Engineers have identified an issue with support emails going to support@shiphero.com not being received. Engineers are working diligently to resolve the issue. Until resolved, please create tickets in our customer portal by logging into the ShipHero application and going to the HELP menu.
Posted Jul 06, 2023 - 14:05 UTC
This incident affected: ShipHero Ticket Support.