DHL Ecommerce is down

Incident Report for ShipHero

Resolved

DHL has resolved the issue.
Posted Apr 21, 2025 - 14:06 UTC

Investigating

DHL Ecommerce is down we are investigating.
Posted Apr 21, 2025 - 12:27 UTC
This incident affected: Label Printing.