Intermittent disruption to shipping
Incident Report for ShipHero
Resolved
This issue has been resolved.
Posted Jun 23, 2020 - 18:50 UTC
Investigating
We are investigating reports of intermittent errors when trying to ship orders.
Posted Jun 23, 2020 - 18:49 UTC
This incident affected: Dashboard and Printing.