Errors of label printing for some orders

Incident Report for ShipHero

Resolved

This incident has been resolved.
Posted Nov 02, 2022 - 19:44 UTC

Identified

There are errors of label printing for some orders. We are working on a fix.
Posted Nov 02, 2022 - 19:35 UTC
This incident affected: Label Printing.