Endicia is currently down for many customers
Incident Report for ShipHero
Resolved
We're no longer seeing Endicia errors and Endicia says the issues is resolved
Posted Nov 30, 2020 - 16:58 UTC
Update
Endicia seems to be partially recovered and is now working intermittently.
Posted Nov 30, 2020 - 16:20 UTC
Update
See https://status.endicia.com/ for updated status.
Posted Nov 30, 2020 - 16:12 UTC
Monitoring
Endicia appears to be down. The issue is on their end and is returning "The remote computer refused the network connection. Error encountered (Log ID: 33353)"
We're monitoring.
Posted Nov 30, 2020 - 16:11 UTC
This incident affected: Label Printing.