Shipping partial outage

Incident Report for ShipHero

Resolved

This issue has been resolved.
Posted Aug 31, 2026 - 03:29 UTC

Identified

We've identified the issue and working on a fix.
Posted Aug 31, 2026 - 02:49 UTC

Investigating

When opening orders on shipping. you may see:
We cannot process this order
We found a problem processing order *****. Please, try again later, or contact ShipHero support.
Hide details
Invalid numeric input value: ****

We are working on resolving this as promptly as possible.
Posted Aug 31, 2026 - 02:39 UTC
This incident affected: Label Printing.