Shipping Rate & Label Printing Slowness
Incident Report for ShipHero
Resolved
Endicia is reporting the issue has been identified and is working to resolve.
Posted 4 months ago. Apr 03, 2019 - 14:53 UTC
Update
Endicia just posted an update that they have identified a technical issue and are working on a resolution.

https://status.endicia.com/
Posted 4 months ago. Apr 03, 2019 - 14:15 UTC
Identified
We are currently tracking a slow service response time with Endicia. We are currently tracking and have asked for more insight.
Posted 4 months ago. Apr 03, 2019 - 13:42 UTC
This incident affected: Printing.