Veho is down and has been disabled

Incident Report for ShipHero

Resolved

Veho is re-enabled and back online
Posted Jul 22, 2026 - 20:12 UTC

Identified

Veho is down within ShipHero due to an API change and has been disabled from quoting. We'll re-enable when we confirm the Veho integration is back to fully functioning.
Posted Jul 22, 2026 - 18:15 UTC
This incident affected: Label Printing.