Experiencing delays with DHL eCommerce
Incident Report for ShipHero
Resolved
The issue has been resolved.
Posted May 14, 2019 - 13:41 UTC
Investigating
We are currently investigating an issue affecting our DHL eCommerce integration.
Posted May 14, 2019 - 13:15 UTC
This incident affected: Label Printing.