Endeavour Experiencing Outage
Incident Report for ShipHero
Resolved
Endeavour issue has been resolved.
Posted Aug 16, 2018 - 13:15 UTC
Investigating
We are currently experiencing an outage on Endeavour services (https://endeavour.shiphero.com).

The team is working to identify the cause and resolve the issue.
Posted Aug 16, 2018 - 12:32 UTC