Printing & Scale Communication Experiencing Delays / Slowness
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Apr 04, 2019 - 13:49 UTC
Identified
We are currently monitoring a service slowdown and are working with our AWS team.
Posted Apr 03, 2019 - 18:03 UTC
This incident affected: Printing.