PO receiving page error
Incident Report for ShipHero
Resolved
This issue is resolved.
Posted Apr 28, 2023 - 15:22 UTC
Identified
We have identified the issue and are working on a fix.
Posted Apr 28, 2023 - 15:03 UTC
Investigating
We are currently investigating an issue causing an error when loading the purchase order receiving page.
Posted Apr 28, 2023 - 14:53 UTC
This incident affected: ShipHero Dashboard.