Buy Shipping by Amazon for Seller Fulfilled Prime is currently down
Incident Report for ShipHero
Resolved
AWS reports the issue is resolved and SysOps have been able to confirm this issue is now resolved.
Posted Aug 14, 2017 - 18:14 UTC
Investigating
SysOps have identified the API is currently down and is investigating the cause.
Posted Aug 14, 2017 - 16:02 UTC