DHL eCommerce
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 19:31 UTC
Investigating
We have been informed that DHL eCommerce is having issues with their API. We will provide an update as soon as we have one.
Posted Dec 17, 2020 - 19:01 UTC
This incident affected: Third Party Services.