Investigating slow down
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted May 26, 2020 - 12:16 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2020 - 11:57 UTC
This incident affected: ShipHero Mobile App and ShipHero Dashboard.