Endicia Experiencing Slow Label Generation & Timeouts
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted 20 days ago. May 06, 2019 - 19:51 UTC
Update
Endicia are reporting all services are running normally.
Posted 20 days ago. May 06, 2019 - 18:11 UTC
Investigating
We are currently monitoring system slowdowns with Endicia label services that will impact our customers using Endicia for rate quoting or label generation.

For information on Endicia status, please visit https://status.endicia.com/
Posted 20 days ago. May 06, 2019 - 16:37 UTC
This incident affected: Printing.