Slow Response Times
Incident Report for ShipHero
Resolved
We have resolved the issues seen with slow response times.
Posted Mar 06, 2020 - 16:05 UTC
Investigating
We are currently investigating slow response times.
Posted Mar 06, 2020 - 16:00 UTC
This incident affected: Label Printing.