Endicia is currently down for many customers
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Oct 20, 2020 - 00:09 UTC
Update
Endicia is reporting service is restored.
Posted Oct 19, 2020 - 21:24 UTC
Identified
See https://status.endicia.com/
When attempting to print Endicia labels you may get an error that looks like "The remote computer refused the network connection." Endicia is working on the issue, it isn't ShipHero specific and isn't related to the ongoing FedEx access issue.
Posted Oct 19, 2020 - 17:58 UTC
This incident affected: Third Party Services.