Order Syncing Delays
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted 30 days ago. Jun 18, 2019 - 15:40 UTC
Investigating
We are currently investigating issues affecting order syncing along with batch picking not showing orders.
Posted 30 days ago. Jun 18, 2019 - 15:10 UTC
This incident affected: Dashboard.