Issue generating USPS labels using Endicia Account
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Aug 06, 2018 - 14:00 UTC
Identified
We are currently aware of an issue preventing the generation of USPS shipping labels with Endicia accounts. Our team has reached out to Endicia to understand when the Endicia team will resolve the issue.
Posted Aug 06, 2018 - 13:29 UTC
This incident affected: Label Printing.