Errors when generating shipping labels
Incident Report for ShipHero
Resolved
The issue has been identified and has been resolved.
Posted Apr 19, 2019 - 20:52 UTC
Investigating
We are currently investigating reports of errors when attempting to generate shipping labels.
Posted Apr 19, 2019 - 20:20 UTC
This incident affected: Label Printing.