FedEx Label Printing Slow
Incident Report for ShipHero
Resolved
FedEx response times have improved. We continue to monitor.
Posted Nov 26, 2018 - 16:58 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 26, 2018 - 16:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 26, 2018 - 16:30 UTC
Monitoring
We're seeing a slowdown in FedEx services that will affect label printing. We continue to monitor. http://www.shippingapimonitor.com/history.html?api=fedex
Posted Nov 26, 2018 - 16:28 UTC
This incident affected: Label Printing.