DHL eCommerce Outage
Incident Report for ShipHero
Resolved
DHL eCommerce has informed us that they are back online at this time.
Posted May 08, 2020 - 14:21 UTC
Monitoring
DHL eCommerce has an outage affecting label printing. You will not be able to print DHL eCommerce labels during the outage. The estimated restoration time is 10:00am EDT.

We continue to monitor and will provide updates as we get them.
Posted May 08, 2020 - 13:13 UTC
This incident affected: Miscellaneous Services.