Intermittent "Network Error" Message when Printing
Incident Report for ShipHero
Resolved
Print services are currently operating normally and we continue to monitor.
Posted Nov 30, 2018 - 20:01 UTC
Identified
There is an issue related to printing services that our engineering team is working to resolve.
Posted Nov 30, 2018 - 17:31 UTC
This incident affected: Label Printing and Miscellaneous Services.