Print Screen Delay
Incident Report for ShipHero
Resolved
The issue has been identified and fixed. Printing performance is operating normally.
Posted 4 months ago. May 28, 2019 - 16:10 UTC
Investigating
We are investigating reports of a slow print screen.
Posted 4 months ago. May 28, 2019 - 14:53 UTC
This incident affected: Printing.