Label printing delays
Incident Report for ShipHero
Resolved
The issue appears to be resolved. We recommend you install the packing app which you can download at https://app.shiphero.com/apps it will be faster and more reliable at all times.
Posted Nov 06, 2020 - 14:56 UTC
Investigating
We're investigating label printing delays for non packing app users. We recommend you use the packing app which you can download at https://app.shiphero.com/apps you will have no delays if you're using the packing apps.
Posted Nov 06, 2020 - 14:48 UTC
This incident affected: Label Printing.