Slow Response Times
Incident Report for ShipHero
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 20:23 UTC
Monitoring
Endicia is working, but still running a bit slow. We will continue monitoring.
Posted Jun 22, 2020 - 17:53 UTC
Identified
The Endicia API is severely degraded. To avoid timeouts, do not use Endicia and do not use Cheapest if you have Endicia connected.
Posted Jun 22, 2020 - 16:39 UTC
Investigating
We are currently investigating this issue.
Posted Jun 22, 2020 - 16:33 UTC
This incident affected: ShipHero Mobile App and Label Printing.