Increased Load Times
Incident Report for ShipHero
Resolved
An update has been reverted and services are operating normally.
Posted 3 months ago. Jun 06, 2019 - 20:01 UTC
Investigating
We are currently investigating reports of increased load times for various features, including viewing orders and order details.
Posted 3 months ago. Jun 06, 2019 - 19:53 UTC
This incident affected: Dashboard.